Dynamic Info ScreenHomeDownloadPrice/OrderScreenshotsHelp/SupportNewsletterXemiComputers
Dynamic Info Screen
 
How to create an info screen project
 


This is a step-by-step guide to creating info screen projects and reading it is highly recommended before you start using the program. An info screen project consists of one or more scenes where each scene can be made of different media objects showing various types of information.

 

The process of creating an info screen project always goes through these steps:

  1 setting up a new project Example included in Dynamic Info Screen
Example included in Dynamic Info Screen
  2 adding a scene and setting its properties
  3 placing and adjusting objects on the canvas
  4 repeating previous two steps for additional scenes
  5 arranging the project's timeline


  1. Setting up a new project
 

Setting up a new projectStart with a New Project option from the Project menu or the Startup Options dialog. This will bring up the New Project dialog where you have two essential things to do. Obviously you need to name your project somehow, but you should pay close attention to the Target screen size parameter.

By default the program offers the resolution of your screen, however, if the info screen you are about to make will play on a computer (or computers) with some different resolution, then you will most likely want to adjust this parameter accordingly.

An obvious question is what to do if an info screen has to play on different computers with different screen resolutions. In that case you should create it for the lowest resolution so it can play on all screens. When played on a higher resolution than the one it was made for an info screen still works fine and appears centered on that larger screen. However, if started on a lower resolution the info screen will not be able to show itself and will just drop out with an error message.

Be aware that if the target screen resolution is higher than resolution of the computer you are using for development, you will not be able to preview and test the project on the development computer. You will still be able to create the project for higher resolution screens but you will have to transfer it to the target computer each time you want to see it in action.

In case you come back to the target screen size parameter later and change it up or down the program will scale all scenes accordingly, but you will have to finish that work manually and fit objects on scenes again.


  2. Adding a scene, and setting its properties
 

In the Scene Properties dialog you can set your own color for its background, use some picture as the scene background, choose an audio file to play while the scene is displayed or enable gradual transition to the next scene. There you also set the border line width and color in case you want media objects to show up framed. While it would be a good practice to set Scene Properties before placing media objects on it you can actually do that whenever you want.

Adding a scene, and setting its properties

  3. Placing and adjusting objects on the canvas
 

Placing and adjusting objects on the canvasTo place a media object on the canvas simply click on it in the Objects Toolbox and then draw a rectangle on the canvas where you want to place it. In case you do not have the Object Toolbox on the screen just enable it in the View menu.

As soon as you finish drawing the object, its Properties dialog will pop-up so you can complete the object setup right away, define contents and adjust parameters according to the object's nature. Of course this is something you can finish later so you can just click OK to close the dialog or click Size & Position to continue with adjusting the object's size and position. To enter the Object Properties dialog again right click on an object and choose Properties or select the object and click the corresponding button on the workspace toolbar.

Each type of media object available with Dynamic Info Screen has its own color code and graphic symbol. This allows for easy recognition on the canvas and a scene thumbnail. By the way, to remove an object from the scene just right click on it and choose Delete or select it and press DELETE on the keyboard.

Four additional options available in the object's right-click context menu are Copy object, Set size/position, Lock size/position and Maximize object. The last two are also available as buttons on the workspace toolbar.

With Copy object option you can make an exact copy of the selected object. All object's properties are retained with an exception for its size that is always reduced to minimum. To paste the object right click on an empty space on the project canvas and a context menu with the Paste object option will appear. Pay attention that overlapping objects is not allowed so if this happens during pasting make sure you correct the situation. You can use copy and paste between different scenes as well.

With Set size/position option you enter a dialog box where you can set the object's size and position precisely, providing of course that there is enough free space available on the canvas. If you enter a value that can not be accepted the program will adjust it automatically.

Of the two options that are also available on the workspace toolbar, the first one, Lock size/position, allows you to fix the object on the canvas so you do not move it nor resize it inadvertently. The second one, Maximize object, will resize the object automatically to get the maximal size as allowed by its position and surrounding objects.

The Objects Toolbox will allow you to select only those objects that can work on the development computer. If you miss some hardware (e.g. web camera) or software components (e.g. DirectX) then depending objects will appear greyed out and you will not be able to use them in your projects. This is true even if you know that target computers that will play the info screen project have different configurations that would satisfy objects' requirements. The only way to overcome this situation is to upgrade the development computer with all missing components.

To preview a scene press F5 on the keyboard, choose Preview Scene option from the Scene menu or click the corresponding button on the workspace toolbar. To exit the preview press ESC or ENTER.


  4. Repeating previous two steps for additional scenes


  5. Arranging the project's timeline
 

Arranging the project's timelineAn info screen project is completed once you finish arranging its timeline. In other words you have to place all scenes in some order and give them durations to round up the project. You will do all that in the Project Timeline floating panel. If the panel is not currently visible on the screen just enable it in the View menu.

If your info screen project has only one scene then there is nothing much to do with its timeline. The first scene of the project is always added to the timeline automatically and gets the default duration of 12h, or if you enter three zeros (0:0:0) then that scene will never end. You will want to make adjustments there only if you want to set a shorter duration for the only scene of the project. When a project plays to the end it automatically starts a new round from the beginning and that happens even for single-scene projects. You can find this fact useful if the scene should update with fresh contents from its online sources.

We explained that the first scene of the project is added to the project's timeline automatically. For all other scenes you have to do that by yourself. This is made like this for a purpose. Rememeber that you have full freedom in assembling an info screen project including the possibility of using the same scene as many times in the timeline as needed.

To add a scene to the timeline simply drag it from the Scene Selector onto the empty scene placeholder that is always at the right end of the Project Timeline. There is also the Add Scene To Timeline option in the Scene menu and a similar option in the context menu available when you right click a scene in the Scene Selector.

To add a special hidden scene to the Project Timeline use the option Add Hidden Scene to Timeline from the Scene menu. During this special scene the info screen project will minimize itself and leave the screen to any other software that is running in the background.

Each scene in the timeline gets its own timer to control the duration within a project with three boxes representing duration in hours, minutes and seconds. The default duration for scenes you add to the timeline is 1h.

You can rearrange the order of scenes in the timeline through drag & drop. To remove a scene from the timeline right click on it and choose Remove from timeline option from the context menu or select the scene and press DELETE on the keyboard.

To preview the project press F6 on the keyboard, choose Preview Project option from the Project menu or click the corresponding button on the workspace toolbar. Note that this kind of preview always starts with the first scene and plays in real time. If your scenes have long durations you can use runtime commands to control the project's execution. To exit the preview press ESC or ENTER, LEFT/RIGHT ARROW to jump to previous/next scene, HOME/END to jump to the first/last scene.

Once you are satisfied with the project's timeline the development is over. Choose Save option from the Project menu or press the corresponding button on the workspace toolbar and you are ready for deployment.

Help & info Center  
Install & Uninstall Registration Creating Projects
Installing Dynamic Info Screen
System requirements (hardware, DirectX, etc.)
Removing and reinstalling Dynamic Info Screen
Installing DirectX
Version History
Free trial period and licensed user rights
Registering Dynamic Info Screen
Lost registration code

How to create an info screen project
Objects Toolbox (enabled/disabled objects)


Deploying Projects DIS Player Project Control

How to deploy an info screen project
Two info screen projects on a dual monitor PC
Displaying a project on multiple screens

Player for Info Screen Projects
Starting a project from the DOS command prompt
Starting a project through a desktop shortcut

Runtime commands
Runtime content editor

Media Objects (click on icon for details)    

Free flash clocks to download - Clocks that allow you to display current time in your info screen projects.
Flash content Slide show Web/HTML page Text lebel PC/WEB camera TV Tuner Media player RSS/Text
© 2008-2014 XemiComputers Ltd.
All Rights Reserved